This site is in read only mode. Please continue to browse, but replying, likes, and other actions are disabled for now.

⚠️ We've moved!

Hi there!

To reduce project dependency on 3rd party paid services the StackStorm TSC has decided to move the Q/A from this forum to Github Discussions. This will make user experience better integrated with the native Github flow, as well as the questions closer to the community where they can provide answers.

Use 🔗 Github Discussions to ask your questions.

Timeout for an Orquesta Workflow

I have a workflow and want to add a timeout to the workflow.

For any reason the workflows doesn’t complete execution (Successfully or with Failure) for a particular amount of time. lets says within 2 hours a workflow does not gives result i want the workflow to be terminated automatically.

i am using orquesta workflows.

1 Like

Hi blag, thanks for sharing the solution. can you help me with how to use -timeout in orquesta.
i am new to stackstorm, so don’t know it , like whether to use as input to workflow or some other way.

when using python action in orquesta, you could add “timeout” key under parameter in the python action’s yaml file:

default: 3600
type: integer

And then add “timeout” in the run() function’s parameters:
def run(self, timeout):

@blag - Having similar problem. Attempting to set a timeout or an orquestra workflow (not tasks in the workflow). You say above " timeout in Mistral, there is a similar option in Orquesta with the same name" - but I can’t find a reference to workflow level timeout in Orquestra source ( Search · timeout · GitHub).
Is there a timeout to set on the Orquestra “runner” or the workflow itself?

It does not seem to be mentioned in the Workflow definition (Orquesta Workflow Definition — StackStorm 3.3.0 documentation) either.


I have the same issue with an orquesta workflow. It looks like my subworkflow hung up because the response of a http action includes a big (but from my perspective not unusual big, around 25k lines) amount of JSON data.
Not the http action hung up. It is the subworkflow itself which is not starting the next task. Therefore I wanted to add a timeout for the subworkflow.

Nevertheless it would only be a workaround as I need to deal with the amount of data. Any idea how to solve the issue or implement timeout on a workflow basis.

See the reference table here:

There is a timeout runner parameter for all of the action runners listed.

Unfortunately I do not see a timeout parameter to the Orquesta action runner itself, so you can’t easily have a subworkflow timeout.

I have opened a feature request for StackStorm to add support for this. You may subscribe to updates on that page.

1 Like