Add EWC to an installed ST2

docker

(qinhao) #1

I’m trying to add Extreme Workflow Composer to ST2. But error occur, error message is
“Error: Package: bwc-enterprise-2.8.1-1.x86_64 (StackStorm_enterprise) Requires: st2 >= 2.8
Error: Package: st2-auth-ldap-2.8.1-1.x86_64 (StackStorm_enterprise) Requires: st2”
ST2 is installed with DOCKER according to this guide Docker — StackStorm 2.8.1 documentation
and when i check the ST2 version is 2.8.1 , obviouslymeets the version requirements

Error message detail :
[root@li1566-230 st2-docker]# sudo yum install -y bwc-enterprise
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • base: mirrors.linode.com
  • epel: mirror.sfo12.us.leaseweb.net
  • extras: mirrors.linode.com
  • updates: mirrors.linode.com
    Resolving Dependencies
    –> Running transaction check
    —> Package bwc-enterprise.x86_64 0:2.8.1-1 will be installed
    –> Processing Dependency: st2flow >= 2.8 for package: bwc-enterprise-2.8.1-1.x86_64
    –> Processing Dependency: st2-auth-ldap >= 2.8 for package: bwc-enterprise-2.8.1-1.x86_64
    –> Processing Dependency: st2 >= 2.8 for package: bwc-enterprise-2.8.1-1.x86_64
    –> Processing Dependency: bwc-ui >= 2.8 for package: bwc-enterprise-2.8.1-1.x86_64
    –> Running transaction check
    —> Package bwc-enterprise.x86_64 0:2.8.1-1 will be installed
    –> Processing Dependency: st2 >= 2.8 for package: bwc-enterprise-2.8.1-1.x86_64
    —> Package bwc-ui.x86_64 0:2.8.1-1 will be installed
    —> Package st2-auth-ldap.x86_64 0:2.8.1-1 will be installed
    –> Processing Dependency: st2 for package: st2-auth-ldap-2.8.1-1.x86_64
    —> Package st2flow.x86_64 0:2.8.1-1 will be installed
    –> Finished Dependency Resolution
    Error: Package: bwc-enterprise-2.8.1-1.x86_64 (StackStorm_enterprise)
    Requires: st2 >= 2.8
    Error: Package: st2-auth-ldap-2.8.1-1.x86_64 (StackStorm_enterprise)
    Requires: st2
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

Check ST2 version info:

[root@li1566-230 st2-docker]# docker-compose exec stackstorm bash
/usr/lib/python2.7/site-packages/requests/init.py:80: RequestsDependencyWarning: urllib3 (1.22) or chardet (2.2.1) doesn’t match a supported version!
RequestsDependencyWarning)
root@e23f12d3bcc0:/# st2 --version
st2 2.8.1, on Python 2.7.6


(Warren) #2

Are you adding BWC to the official st2-docker 2.8.1 image? If yes, then I guess you installed yum since it isn’t installed in the official image. st2 packages are installed by apt-get, so yum may not be aware of the installed packages, thus figuring that st2 is not installed.

If some other image, share the Dockerfile?


(qinhao) #3

yes. the os system is centos7; Trying to add EWC to st2-docker 2.8.1;

ST2 is installed exactly according this guide Docker — StackStorm 2.8.1 documentation

and add EWC exactly according this guide Installing Extreme Workflow Composer — StackStorm 2.8.1 documentation CentOS part;

what should i do to solve this probleam?


(Lindsay Hill) #4

The Docker base image is Ubuntu, not CentOS. If you’re adding EWC, you need to follow the Ubuntu instructions. Something like this:

# Set up Extreme Workflow Composer repository access
curl -s https://${EWC_LICENSE_KEY}:@packagecloud.io/install/repositories/StackStorm/enterprise/script.deb.sh | sudo bash
# Install Extreme Workflow Composer
sudo apt-get install -y bwc-enterprise

(Lindsay Hill) #5

If that doesn’t work, provide the output of

uname -a
dpkg -l st2\*
yum list st2\*

(qinhao) #6

thanks a lot. problem solved.