Allowing large results in Mistral workflows

howto
workflows
mistral

(Nick Maludy) #1

NOTE Processing large messages may degrade performance of both Mistral and StackStorm.

Sometimes it is necessary to process large messages and/or the output inside a workflow grows to a large size. You will run into problems in Mistral where it will disallow these large messages and throw errors in /var/log/mistral/mistral-server.log.

Here is how to enable large message handling.

  1. Edit the mistral config /etc/mistral/mistral.conf. This allows Mistral to handle large message internally.
[engine]
# disable execution size checking
execution_field_size_limit_kb = -1
  1. Edit the nginx config /etc/nginx/conf.d/st2.conf you’ll need to modify both server sections. This allows the callbacks from Mistral -> StackStorm to succeed with a large message.
server {
    # disable body size checking
    client_max_body_size 0;
  1. Restart nginx, StackStorm and Mistral
systemctl reload nginx
st2ctl restart