Authentication failed? No actions, sensors, trrigers appear on GUI. ((+_+))

Similar to the problem: HTTP 503 - Running st2 run tutorial.hello · Issue #177 · StackStorm/st2-docker · GitHub

Hello from JP.
I will talk about the backgroud with this issue.

On the other day, I tried to install PowerCLI , so set the proxy configuration on “/etc/profile” .
Then it succeeded and the purpose was accomplished.

Today, I was going to run the action on my St2 server, then I executed on St2 console following and got the error like that.

st2 run XYZ.yaml


ERROR: 503 Server Error: Service Unavailable
Unable to retrieve detailed message from the HTTP response. Expecting value: line 1 column 1 (char 0)
for url: http://127.0.0.1:9100/tokens

In addition, sadly, GUI became to appear uncompletely ((+_+))

I wondered the port9100 was not LISTENING ? , however the port was LISTEN according to the netstat command.

After I confused and research, found the following QA finally.

According to that QA, all I have to do is to set no_proxy about RoopBackAddress.
Then I set so.
export no_proxy=localhost,127.0.0.1

After that, I tried to confirm the movement of St2 by using “st2 --debug action get XYZ”.
However, the answer is Using cached token from file “/root/.st2/token-st2admin” .
And it was not executed completly…

why this was happend, what should do I…,

× st2 run XYZ.yaml
〇 st2 run XYZ