Can't install version 2.8.1

install

(Kyle Kimberley) #1

I need to install version 2.8.1 on a CentOS virtual machine, but every path I’ve tried so far (except vagrant, which I can’t use for what I need to do) either forces me to install 2.9 or is a failure of some sort. Can someone give me some help to get 2.8.1 installed?

I thought installing from sources would be my best bet, so I downloaded the 2.8 branch zip, but it fails with this message:
Finished processing dependencies for st2common==2.8.1
# Some of the tests rely on submodule so we need to make sure submodules are check out
git submodule update --init --recursive
fatal: Not a git repository (or any of the parent directories): .git
make: *** [requirements] Error 128

Is there a a no tests option when building?
I can’t use the git repo, because that installs 2.9.

Thanks in advance


(Eugen C.) #2

Which installation methods did you try already from Installation — StackStorm 2.9.1 documentation?

For demo one-line scripted install, the command to deploy v2.8.1 is the following:

curl -sSL https://stackstorm.com/packages/install.sh | bash -s -- --version=2.8.1 --user=st2admin --password='Ch@ngeMe'

I wouldn’t recommend to install from sources, as it’s something useful for development environment only.

There are also other different methods: Docker, Ansible, Chef, Puppet and manual install step-by-step, - every method offers versioning pinning.


(Kyle Kimberley) #3

Thanks @armab
I couldn’t find documentation on how to set the version on that command. I’ll give it a try.


(Kyle Kimberley) #4

That worked marvelously.