ChatOps is online but "!help" only works


(Anfey) #1

Greetings.

I have a problem during chatops setup. Looks like I’ve missed something small but important.

What I did:

  1. Installed stackstorm locally using this guide on macos: Docker — StackStorm 2.10.1 documentation
  2. Set up basic chat flow using this guide: What is ChatOps? — StackStorm 2.10.1 documentation
  3. Enabled chatops in docker image:

sudo rm /etc/init/st2chatops.override
st2ctl reload --register-all

What I expect:
!run date on localhost and/or !st2 list actions should return some result in chat

What I have:
The bot is online and answering, but only !help works.

I’ve tried slack hubot adapter and telegram - same result. Tested on docker images stackstorm/stackstorm:2.10 and stackstorm/stackstorm:latest.

Followed instructions - does not help ChatOps Troubleshooting Guide — StackStorm 2.10.1 documentation

vkfont [7:19 PM]
!run date on localhost
!st2 list actions
!help

hubot APP [7:20 PM]
!help - Displays all of the help commands that this bot knows about.
!help <query> - Displays all help commands that match <query>.

Additional debug information:

docker -v
Docker version 18.09.1, build 4c52b90

st2 --version
st2 2.10.1, on Python 2.7.6

uname -a
Linux 2c24744518b1 4.9.125-linuxkit #1 SMP Fri Sep 7 08:20:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

python --version
Python 2.7.6

st2-submit-debug-info
st2-debug-output-2c24744518b1-2019-01-28-163346.tar.gz.asc

st2 action-alias list
±--------------------------±---------±-------------------------------------------±--------+
| ref | pack | description | enabled |
±--------------------------±---------±-------------------------------------------±--------+
| examples.remote_shell_cmd | examples | Execute a command on a remote host via | True |
| | | SSH. | |
| packs.pack_get | packs | Get information about installed StackStorm | True |
| | | pack. | |
| packs.pack_install | packs | Install/upgrade StackStorm packs. | True |
| packs.pack_search | packs | Search for packs in StackStorm Exchange | True |
| | | and other directories. | |
| packs.pack_show | packs | Show information about the pack from | True |
| | | StackStorm Exchange. | |
±--------------------------±---------±-------------------------------------------±--------+

tail /var/log/st2/st2chatops.log
https://gist.github.com/afoninsky/a1c2acf906230f8f5a0df76dff2aca72


(Anfey) #2

Just figured out.
Forgot about:

export ST2_API=https://localhost/api
export ST2_AUTH_URL=https://localhost/auth
export ST2_API_KEY=...

Sorry my bad :slight_smile:


(Warren) #3

Heh. I was just about to mention that in your st2chatops.log, I see

[Mon Jan 28 2019 16:19:08 GMT+0000 (Coordinated Universal Time)] ERROR Failed to authenticate: Invalid or missing credentials

When I was testing your procedure, I noticed that ST2_API_KEY needed to be set. So glad you found it!