[HOWTO] Fix tooz connection timeouts with uri

There are optional settings you can add to your coordinator uri to fix errors like socket timeouts.

For redis see:
https://github.com/openstack/tooz/blob/6e7a8508fbcbe9ceacb04490dc8330501bfa2477/tooz/drivers/redis.py#L141

In my specific situation I set my coordinator setting in st2.conf to:

[coordination]
url = redis://127.0.0.1:6379?socket_timeout=90
lock_timeout = 180
2 Likes

Thanks @guzzijones, would you add this to the docs on the policies page?

1 Like