Insecure request warning - python 3 action

when I run an action through a workflow it is run by stanley user. I always see insecurerequestwarning in the stderr. Is there a way in python3 to disable this warning since stanley is connecting to localhost?

  InsecureRequestWarning,```

I was able to disable them in my custom action by adding the following:

urllib3.disable_warnings(urllib3.exceptions.InsecureRequestWarning)

The other option is to use the host name in the valid certificate I installed, but since it is localhost I don’t really have concerns about ssl

Yep, that should do it.

And for the CLI (st2client), you can achieve the same thing by setting general.silence_ssl_warnings = True config option in ~/st2/config.