Packs search takes 5 minutes to respond

I’ve deployed Stackstorm-HA (helm v0.60.0) and noticed that after logging into the Web UI that the Packs tab is completely blank while other tabs like Actions and Rules etc have all populated correctly

I then discovered that /api/v1/packs/index returns a 504 response (/api/packs/ however returns my installed packs no problem)

On the cli if i run “st2 pack search xxx” then it does eventually return the result but it takes around 5mins to complete every time

I’ve now enabled Debug mode and this is what I’m seeing in the API service

2021-04-16 03:30:48,279 DEBUG [-] Proxy configuration: {'http_proxy': None, 'https_proxy': None, 'proxy_ca_bundle_path': None, 'no_proxy': None}
2021-04-16 03:30:48,280 DEBUG [-] Starting new HTTPS connection (1): index.stackstorm.org:443
2021-04-16 03:35:08,804 DEBUG [-] https://index.stackstorm.org:443 "GET /v1/index.json HTTP/1.1" 200 76037
2021-04-16 03:35:08,812 DEBUG [-] Using response spec "200" for endpoint st2api.controllers.v1.packs:packs_controller.index.search.post and status code 200
2021-04-16 03:35:08,813 DEBUG [-] Match path: /packs/index/search

I couldn’t find any errors but I can see that it really is waiting 5 minutes between “Starting new HTTPS Connection” and actually issuing the GET request

If I run ‘curl https://index.stackstorm.org/v1/index.json’ from the API container it pulls the full json file in less than a second so I don’t understand why the API service is taking so long!

Any ideas?

Thanks,
Chris