Quick Install stackstorm error

I tried to install St2 with one-line command suggested on stackstorm website following that:

curl -sSL https://stackstorm.com/packages/install.sh | bash -s – --user=st2admin --password=‘Ch@ngeMe’

An error occured .
url: (7) failed to connect to raw.githubusercontent.com.port 443:connection refused

How to solve this error, thank you!!


https://www.githubstatus.com/ does not show any ongoing incidents and it works fine for me. So I guess it’s a client or network issue on your end.

What happens if you try to curl https://raw.githubusercontent.com/StackStorm/st2-packages/master/scripts/st2bootstrap-deb.sh or curl https://raw.githubusercontent.com/StackStorm/st2-packages/master/scripts/st2bootstrap-el7.sh if you are on RedHat?

You may wanna run curl with -v to get more verbose output if the curl calls fail, too.

If you can not solve it with the information provided by curl please provide more details about the operating system, network infrastructure (are you behind a proxy?) and the log at least.


The curl call fails. Run curl with -v to get more verbose output as shown below

I installed stackstorm on a virtual machine with Ubuntu 18.04(ubuntu-18.04.4-live-server-amd64) and no proxy. The system is a clean linux system.

I cannot access the URL(https://stackstorm.com/packages/install.sh)


this is clearly something out of our control.

The curl output shows that curl resolves the domain to which is obviously wrong. What confuses me is that curl actually fails when it can’t resolve a domain to an address. So I would check your local DNS client and the configured DNS servers. You can also run dig @<your-dns-ip-address> raw.githubusercontent.com to see if the resolution works.

And I just notice that this can also be some kind of “security” applied by your network operator so that he prevents access to a set of domains by resolving them to I guess you are in any kind of company or public network?

This is unfortunately we can not really fix and needs to be solved on the client side.


Quick installation has been unsuccessful. Later, I tried to install manually, but prompted “E: Unable to locate package st2” when installing StackStorm components. The command “sudo apt-get update” reports an error, the information is as follows:

operation@ops_center:~ sudo apt-get install -y st2 Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package st2 operation@ops_center:~ sudo apt-get update
Hit:1 http://mirrors.aliyun.com/ubuntu bionic InRelease
Hit:2 http://mirrors.aliyun.com/ubuntu bionic-updates InRelease
Hit:3 http://mirrors.aliyun.com/ubuntu bionic-backports InRelease
Hit:4 http://mirrors.aliyun.com/ubuntu bionic-security InRelease
Ign:5 http://repo.mongodb.org/apt/ubuntu bionic/mongodb-org/4.0 InRelease
Hit:6 http://repo.mongodb.org/apt/ubuntu bionic/mongodb-org/4.0 Release
Get:8 https://packagecloud.io/StackStorm/stable/ubuntu bionic InRelease [23.2 kB]
Err:8 https://packagecloud.io/StackStorm/stable/ubuntu bionic InRelease
The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 3CE01873543A4CCE
Reading package lists… Done
W: GPG error: https://packagecloud.io/StackStorm/stable/ubuntu bionic InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 3CE01873543A4CCE
E: The repository ‘https://packagecloud.io/StackStorm/stable/ubuntu bionic InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Can you provide a solution?
thank you!!!

Is the server version of Ubutun 18.04 system installed?
As shown in the second image in the red box。