st2.actions.python.St2RegisterAction Failed


(santosh) #1

Hi,

I am trying to install pack unable to register pack

  File "/opt/stackstorm/st2/lib/python2.7/site-packages/requests/adapters.py", line 502, in send
    raise ConnectionError(e, request=request)
requests.exceptions.ConnectionError: HTTPConnectionPool(host='0.0.0.0', port=8080): Max retries exceeded with url: /v1/packs/register (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f477caaee10>: Failed to establish a new connection: [Errno 111] Connection refused',))

traceback: None
failed_on: register pack
start_timestamp: Thu, 17 Jan 2019 16:38:46 UTC
end_timestamp: Thu, 17 Jan 2019 16:39:17 UTC
+--------------------------+-------------------------+----------------------+----------------------+------------------+
| id                       | status                  | task                 | action               | start_timestamp  |
+--------------------------+-------------------------+----------------------+----------------------+------------------+
| 5c40af97543cff6726b49640 | succeeded (13s elapsed) | download pack        | packs.download       | Thu, 17 Jan 2019 |
|                          |                         |                      |                      | 16:38:47 UTC     |
| 5c40afa4543cff6726b49642 | succeeded (2s elapsed)  | make a prerun        | packs.virtualenv_pre | Thu, 17 Jan 2019 |
|                          |                         |                      | run                  | 16:39:00 UTC     |
| 5c40afa6543cff6726b49644 | succeeded (9s elapsed)  | install pack         | packs.setup_virtuale | Thu, 17 Jan 2019 |
|                          |                         | dependencies         | nv                   | 16:39:02 UTC     |
| 5c40afb0543cff6726b49646 | failed (4s elapsed)     | register pack        | packs.load           | Thu, 17 Jan 2019 |
|                          |                         |                      |                      | 16:39:12 UTC     |
+--------------------------+-------------------------+----------------------+----------------------+------------------+

(Lindsay Hill) #2

Just closing the loop, with info uncovered via Slack, this issue was due to misconfigured api_url in /etc/st2/st2.conf.