St2 HA components not running

Hello guys,
I installed st2 HA. All my pods are in running state. But, when I execute st2ctl reload from inside of st2client pods, the status of the services are shown as not working.

root@happy-labradoodle-st2client-5bc549bc48-fmjvm:/etc/default# st2ctl reload
Registering content...[flags = --config-file /etc/st2/st2.conf --config-file=/etc/st2/st2.docker.conf --config-file=/etc/st2/st2.user.conf --register-runners --register-actions --register-aliases --register-sensors --register-triggers --register-configs --register-rules]
2020-07-18 17:41:40,351 INFO [-] Connecting to database "st2" @ "happy-labradoodle-mongodb-ha-0.happy-labradoodle-mongodb-ha:27017,happy-labradoodle-mongodb-ha-1.happy-labradoodle-mongodb-ha:27017,happy-labradoodle-mongodb-ha-2.happy-labradoodle-mongodb-ha:27017 (replica set)" as user "admin".
2020-07-18 17:41:40,366 INFO [-] Successfully connected to database "st2" @ "happy-labradoodle-mongodb-ha-0.happy-labradoodle-mongodb-ha:27017,happy-labradoodle-mongodb-ha-1.happy-labradoodle-mongodb-ha:27017,happy-labradoodle-mongodb-ha-2.happy-labradoodle-mongodb-ha:27017 (replica set)" as user "admin".
2020-07-18 17:41:40,853 INFO [-] =========================================================
2020-07-18 17:41:40,853 INFO [-] ############## Registering triggers #####################
2020-07-18 17:41:40,853 INFO [-] =========================================================
2020-07-18 17:41:40,952 INFO [-] Registered 0 triggers.
2020-07-18 17:41:40,952 INFO [-] =========================================================
2020-07-18 17:41:40,952 INFO [-] ############## Registering sensors ######################
2020-07-18 17:41:40,952 INFO [-] =========================================================
2020-07-18 17:41:40,979 INFO [-] Registered 1 sensors.
2020-07-18 17:41:40,979 INFO [-] =========================================================

2020-07-18 17:41:40,979 INFO [-] ############## Registering runners ######################
2020-07-18 17:41:40,979 INFO [-] =========================================================
2020-07-18 17:41:41,920 INFO [-] Registered 14 runners.
2020-07-18 17:41:41,921 INFO [-] =========================================================
2020-07-18 17:41:41,921 INFO [-] ############## Registering actions ######################
2020-07-18 17:41:41,921 INFO [-] =========================================================
2020-07-18 17:41:43,589 INFO [-] Registered 73 actions.
2020-07-18 17:41:43,589 INFO [-] =========================================================
2020-07-18 17:41:43,589 INFO [-] ############## Registering rules ########################
2020-07-18 17:41:43,589 INFO [-] =========================================================
2020-07-18 17:41:43,721 INFO [-] Registered 3 rules.
2020-07-18 17:41:43,721 INFO [-] =========================================================
2020-07-18 17:41:43,721 INFO [-] ############## Registering aliases ######################
2020-07-18 17:41:43,721 INFO [-] =========================================================
2020-07-18 17:41:43,796 INFO [-] Registered 4 aliases.
2020-07-18 17:41:43,796 INFO [-] =========================================================
2020-07-18 17:41:43,797 INFO [-] ############## Registering configs ######################
2020-07-18 17:41:43,797 INFO [-] =========================================================
2020-07-18 17:41:43,815 INFO [-] Registered 2 configs.

st2 components status

st2actionrunner is not running.
st2api is not running.
st2stream is not running.
st2auth is not running.
st2garbagecollector is not running.
st2notifier is not running.
st2resultstracker is not running.
st2rulesengine is not running.
st2sensorcontainer is not running.
st2chatops is not running.
st2timersengine is not running.
st2workflowengine is not running.
st2scheduler is not running.

I did try doing sysctl enable , but didnt work. Can someone help me. TIA.