StackStorm Installation Issue

Hi,
I am following steps provided in “Run From Sources — StackStorm 3.2.0 documentation” to setup stackstorm in OEL7 VM in corporate environment. The “make requirements” command execution is getting stuck at a stage saying:

Fix for Travis CI race

virtualenv/bin/pip install “six==1.12.0”
ERROR: Could not find a version that satisfies the requirement six==1.12.0 (from versions: none)
ERROR: No matching distribution found for six==1.12.0

Though package six is updated to 1.13.0 as per the requirements.txt file in st2 folder. If manually i install six==1.12.0, it gives error like:

ERROR: Could not find a version that satisfies the requirement six==1.13.0 (from -r requirements.txt (line 59)) (from versions: none)
ERROR: No matching distribution found for six==1.13.0 (from -r requirements.txt (line 59))

Actually i have 2 different export proxy settings, for one of which, only pip commands are working and for the other only git commands are working. So the entire “make requirements” is not going through without manually installing some packages parallely. After installing all the packages though, only facing this issue with “six” version and getting stuck. If i use the proxy that’s working for pip commands, then its getting stuck at below and exiting after a timeout(because this proxy won’t allow git commands to run):

Some of the tests rely on submodule so we need to make sure submodules are check out

    git submodule update --recursive --remote

Kindly please suggest. Also please let me know if any other information is required. Thanks.

Python Version=2.7
Pip Version=20.0.2
Git RPM=git-1.8.3.1-22.el7_8.x86_64

Can you please try starting over? Seems like something went wonky.