Ubuntu 14.04 support dropped in ST2 3.1

StackStorm 3.1 will be dropping support for Ubuntu 14.04.

It will add GA support for Ubuntu 18.04, with all services running with Python 3.

See System Requirements — StackStorm 3.1dev documentation for the system requirements.

Later this year RHEL 8.x will be added, and RHEL 6.x will be dropped.