Ubuntu 18.04 support - no gnupg-curl in 18.04 yet

On Ubuntu 18.04, has anyone tried either the one-line install or the manual installation? I am getting stuck at installing gnupg-curl – it looks like gnupg-curl is not available yet in 18.04. Hoping this will mitigated with release of ST2 3.1.

If you install using the one-line installer, pass in the --unstable flag. That will then pull in 3.1-prerelease packages.

Looks like the installer script bypasses gnupg-curl install for Bionic. Presumably not needed any more. See st2-packages/st2bootstrap-deb.sh at master · StackStorm/st2-packages · GitHub

Looks like we might need to make an update to those docs. That’s why they’re in pre-release, so we can pick up those bugs before GA. Could submit a PR for that doc please?

Thanks for your quick reply! Very very helpful. I submitted a proposal on github here. Please let me know if that is what you were looking for.

Can you recommend the full one-line install including the --unstable flag? I am using the one-line install command below and --unstable flag is producing errors:

curl -ksSL https://stackstorm.com/packages/install.sh | bash -s – --user=st2admin --password=‘Ch@ngeMe’

I have opted to rebuild my server on 16.04. I was never able to get this working with either of these one-line installs (–unstable included in the second command):

/apps [513]$ curl -ksSL https://stackstorm.com/packages/install.sh | bash -s -- --user=st2admin --password='Ch@ngeMe'
*** Detected Distro is Ubuntu ***
*** Detected flavor bionic ***
Could not find file https://raw.githubusercontent.com/StackStorm/st2-packages/v3.1/scripts/st2bootstrap-deb.sh



/apps [514]$ curl -ksSL https://stackstorm.com/packages/install.sh | bash -s -- --unstable --user=st2admin --password='Ch@ngeMe'
*** Detected Distro is Ubuntu ***
*** Detected flavor bionic ***
Could not find file https://raw.githubusercontent.com/StackStorm/st2-packages/master/scripts/st2bootstrap-deb.sh

Could not find file https://raw.githubusercontent.com/StackStorm/st2-packages/v3.1/scripts/st2bootstrap-deb.sh

Could not find file https://raw.githubusercontent.com/StackStorm/st2-packages/master/scripts/st2bootstrap-deb.sh

I checked and found no issues with them.

Can you double-check again? Can you curl these URLs from your instance, what’s the output?

Hi Eugen, thanks for the support. When I curled those URLs, they appeared to download just fine. However, when I run the one-line install with and without --unstable, it gives me the same output as my last post.

I just ran some tests here with a clean Ubuntu 18.04 system, and all worked as expected.

The relevant section of the script is here:

CURLTEST=`curl --output /dev/null --silent --head --fail ${ST2BOOTSTRAP}`
if [ $? -ne 0 ]; then
    echo -e "Could not find file ${ST2BOOTSTRAP}"
    exit 2
else

Earlier it sets $ST2BOOTSTRAP to https://raw.githubusercontent.com/StackStorm/st2-packages/master/scripts/st2bootstrap-deb.sh, as you can see in your error message.

Note the use of --head there in the curl command. I have seen some systems have issues related to the HEAD directive. Proxies in your network maybe?

What happens if you run this:

curl --head --fail https://raw.githubusercontent.com/StackStorm/st2-packages/master/scripts/st2bootstrap-deb.sh

Note I’ve removed the --silent directive, to see if we can get some more info about what’s going on here.

Appreciate all the help StackStorm team! I saw that same block earlier as well. The proxy question may not be answerable at this time due to this VM is in an Azure cloud that I do not admin. However here is the output of the recommended command:

/apps [527]$ curl -k --head --fail https://raw.githubusercontent.com/StackStorm/st2-packages/master/scripts/st2bootstrap-deb.sh
HTTP/1.1 200 OK
Content-Type: text/plain; charset=utf-8
Content-Security-Policy: default-src ‘none’; style-src ‘unsafe-inline’; sandbox
Strict-Transport-Security: max-age=31536000
X-Content-Type-Options: nosniff
X-Frame-Options: deny
X-XSS-Protection: 1; mode=block
ETag: “aad11023bba2d25bede259b3e8d2695a7037adcd”
Cache-Control: max-age=300
X-Geo-Block-List:
X-GitHub-Request-Id: 93BE:33F6:2766C:33C35:5D155F29
Content-Length: 26514
Accept-Ranges: bytes
Date: Fri, 28 Jun 2019 00:28:42 GMT
Via: 1.1 varnish
Connection: keep-alive
X-Served-By: cache-mdw17362-MDW
X-Cache: MISS
X-Cache-Hits: 0
X-Timer: S1561681723.788457,VS0,VE132
Vary: Authorization,Accept-Encoding, Accept-Encoding
Access-Control-Allow-Origin: *
X-Fastly-Request-ID: 789c195d87377d7bde5f97b3128e1e1d2e7d4edb
Expires: Fri, 28 Jun 2019 00:33:42 GMT
Source-Age: 0

That looks about right - it seems to succeed there. No obvious reason why it should fail when run as part of the install script.

There’s no real magic in that script. Basically all it’s really doing there is figuring out which branch of the installer script to get (master for unstable, otherwise versioned, e.g. 3.0, 3.1), and then pulling the OS-specific script.

Since it looks like you can download the st2bootstrap-deb.sh script, you could try just running that one directly.

Also, FYI: 3.1 release is in progress now. When that is finalized, Ubuntu 18.04 support is GA

Noted about the 3.1, and thanks again! I will still need to get this up and running even if it is on Ubuntu 16.04.

However, breakthrough! I ran the command below, which triggered the stackstorm unstable install. Unfortunately, it failed due to the error below. Any slight changes you can recommend to workaround this error? It does seem related to the title of this post - gnupg-curl, 18.04, etc.

/apps [542]$ curl -ksSL https://raw.githubusercontent.com/StackStorm/st2-packages/master/scripts/st2bootstrap-deb.sh | bash -s -- --unstable --user=st2admin
--password='Ch@ngeMe'
########################################################
          Installing StackStorm unstable
########################################################
[sudo] password for bcm9576:
Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease
....
Setting up crudini (0.7-1) ...
gpg: no valid OpenPGP data found.
############### ERROR ###############
# Failed on Install st2 dependencies (MongoDB) #
#####################################
/apps [543]$

I’ve never seen that error before. You’ll need to figure out what local restrictions or non-standard things you have in your environment.

If you can’t use the script, do a manual install (docs.stackstorm.com/install/deb.html). You’ll need to debug why your system can’t download standard packages.

I can confirm this error was due to my self-signed cert. I was able to get a cert solution to bypass this.