Unable to Install Packs From GUI without specifying Python3 in command line

Hi,

I installed StackStorm on RedHat7. But, when downloading packs through the command line, I get the following error for all packs

Pack “xxx” requires Python 3.x, but current Python version is “2.7.5”. You can override this restriction by providing the “force” flag, but the pack is not guaranteed to work

However, if I specify st2 pack install xxx --python3, it installs fine. This prevents me from installing packs through the GUI. I was wondering if anyone is facing the same problem and has a solution. I have both python 2.7 and python 3.6 installed.

What version of StackStorm are you using?
st2 --version

I am using st2 3.3.0, on Python 2.7.5

All packs have had their latest version number upped and restricted to python3, as StackStorm 3.4.0 will only support python3.

Although the “packs” menu at the top of the UI doesn’t allow you to specify any parameters to pack install. If you instead use the Actions menu, and choose Packs->Install as the action. You can then specify parameters such as python3.

So you can therefore install them with python3 boolean that way, or specify the version number of the pack, and choose the version that last supported python 2.

Thank You! It worked now.