This site is in read only mode. Please continue to browse, but replying, likes, and other actions are disabled for now.

⚠️ We've moved!

Hi there!

To reduce project dependency on 3rd party paid services the StackStorm TSC has decided to move the Q/A from this forum to Github Discussions. This will make user experience better integrated with the native Github flow, as well as the questions closer to the community where they can provide answers.

Use 🔗 Github Discussions to ask your questions.

Unable to launch UI page

Hi All,

I have just completed a fresh installation and for some reason unable to launch the webapge. All the components are running fine, I am guessing it is an issue with nginx server failing to bind the IP.

Tried following this link, but not sure (update-system) mentioned at the end of the page.



What makes you think it’s an nginx binding problem? Are there some logs to indicate that? Or are you not seeing 443 in netstat -nltp?

My guess is that you have default RHEL/CentOS system firewall on, blocking inbound traffic.

Hi Lindsay,

The reason for considering binding problem, this server has mutliple NIC’s. I could not see any logs all files in /var/log/nginx/ are 0 bytes size. I can see all ports are listening

Also, I dont think its a firewall issue because iptables are disabled.

[email protected]:/opt/stackstorm# service iptables status
iptables: Firewall is not running.

Please guide me.


If it was a binding problem, you would not see :443 in your output above.

this server has mutliple NIC’s.

That is probably at least partly related to your issues.

At this point it’s just a standard network troubleshooting process. Check that DNS resolves as you expect. Trace the packets between your client and the server. Identify any firewalls or misconfigured routing. Check that packets are received on the server. Check that the reverse path, from server to client is what you expect.

Talk to your sysadmins and network engineers if you aren’t familiar with this process


Thanks for the all the inputs, was able to resolve the issue with eth2 interface name.



Can you please help me with the resolution, I am having the same issue

@lesnarwwe there are a few troubleshooting steps in the posts above. Have you tried those? What did you find? What’s working? What’s not working?

Hi @lhill Thanks for responding, actually we did troubleshoot all the port issues and service status, it was merely a firewall issue where the IP was blocked on port 443, its working now