This site is in read only mode. Please continue to browse, but replying, likes, and other actions are disabled for now.

⚠️ We've moved!

Hi there!

To reduce project dependency on 3rd party paid services the StackStorm TSC has decided to move the Q/A from this forum to Github Discussions. This will make user experience better integrated with the native Github flow, as well as the questions closer to the community where they can provide answers.

Use 🔗 Github Discussions to ask your questions.

While Installation tool , getting an error for "Peer's Certificate issuer is not recognized."

Command- https:// (curl -s | sudo bash )

Error**" [Errno 14] curl#60 - “Peer’s Certificate issuer is not recognized.”**

OS-Tried on RHEL 7.6 and Centos 7

Please suggest

Are you behind a proxy or using any custom company-issued CA certificate? If so, you have to figure out with your networking/sysadmin team to be able accessing from your network.

Also googling might help:

i am not using any Proxy or any certificate , This Machine is on my VMware , this is Machine is created by me.


yum reinstall ca-certificates

to update the certificates on your machine.

I have run the above command in my system and got following error.

[[email protected] ~]# yum reinstall ca-certificates
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
epel/x86_64/metalink | 18 kB 00:00:00

One of the configured repositories failed (StackStorm_stable),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=StackStorm_stable ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable StackStorm_stable
        subscription-manager repos --disable=StackStorm_stable

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice

        yum-config-manager --save --setopt=StackStorm_stable.skip_if_unavailable=true

failure: repodata/repomd.xml from StackStorm_stable: [Errno 256] No more mirrors to try. [Errno 14] curl#60 - “Peer’s Certificate issuer is not recognized.”

How about following the recommendations from the log message? Try this:

yum --disablerepo=StackStorm_stable reinstall ca-certificates curl

I am able to resolve the issue ,

thank you all !!

Cool, thanks for getting back to us!

If you could share some quick pointers how you investigated and fixed it, - that would be helpful for someone else in our community experiencing similar issues.

there was issue related to OS, firstly i used CentOs and then tried to download CA certificate online and installed that on server , then it started communicate with secure connections.