Workflow failed - Please help


(Deepchandna) #1

Issue resolved and data sent to bin


(Lindsay Hill) #2

You have a syntax error in your workflow definition. Fix that.


(Lindsay Hill) #3

Also, if you need help with your workflow, you need to publish that. We can only guess at the syntax errors based on that traceback.

If your workflows can’t be posted here, there are professional services firms that can be engaged under NDA


(Deepchandna) #4

Thanks much. Let me try that.


(Lindsay Hill) #5

Let me know if you need a reference - there are several very good PS firms with ST2 skills


(Deepchandna) #6

Issue resolved and data sent to bin


(Deepchandna) #7

@lhill , Can you please help me here!


(Lindsay Hill) #8

Have you done any investigation into what’s going? Have you tried to break your problem down into smaller steps, to see what’s working and what’s not? Has this ever worked? If it did work in the past, what changed between now & then?

1/ I would start by looking at your workflow definition
2/ The traceback has an error line - start by looking at that to see what the error is.
3/ Like I said before, without the workflow I can’t tell you what to fix. If you urgently need support, and you can’t share details about your workflow, I can put you in touch with paid professional services who can operate under an NDA.


(Lindsay Hill) #9

What’s different with the second traceback you posted? Or is it the same thing again?


(Deepchandna) #10

Issue resolved and data sent to bin


(Deepchandna) #11

Issue resolved and data sent to bin


(Deepchandna) #12

These are two workflows . Please check it.


(Deepchandna) #13

Issue resolved and data sent to bin


(Lindsay Hill) #14

Please fix the formatting on those workflows. You can use the formatting icons, or you can use markdown, e.g. put “```yaml” before a yaml block, similar to Github Markdown. Right now it’s a wall of text


(Lindsay Hill) #15

Which workflow is causing problems? Have you tried validating the YAML (e.g. with https://codebeautify.org/yaml-validator), or validating the mistral syntax - e.g. with this Mistral — StackStorm 2.8.1 documentation

What troubleshooting steps have you done so far?


(Deepchandna) #16

Issue resolved and data sent to bin


#18

Please use Markdown to format text that you have copied and pasted here as code - it’s really hard to parse walls of text.


(Deepchandna) #20

Issue resolved and data sent to bin


(Deepchandna) #21

Please help. Code is pasted above.


(Lindsay Hill) #22

Please use proper formatting for pasting code. It’s almosg impossible to tell what’s going on. Use Markdown, as both blag and I have asked